Welcome Guest ( Log In | Register )


 
Reply to this topicStart new topic
> Fight Banner
Lexx
post Dec 25 2009, 09:48 AM
Post #1


Newbie
*

Group: Members
Posts: 35
Joined: 30-November 09
From: Germany
Member No.: 1,027



A new question from me... This time about the fight banner. I am fiddling around with it already since some days and don't get it to work 100%. What I get: The fight banner themself are working, this is no problem with the fight_banner entity. But I still have questions open... as example, ingame I can't see the "vs" image on top of the screen. Also I am unsure about the display time and how to freeze the game in a correct way.

For doing my homeworks, I am using the tool "entspy", to check out the entities in a map (tried to decompile some maps too, but this doesn't work because of prop errors.) Anyway...

Here some details about what I have:
1x trigger_once
1x fight_banner
1x freezeplayer_game_ui
1x color_correction
1x playerproxy

In Short:
The trigger once is activating the fight_banner, which is activating the freezeplayer_game_ui and the color_correction and the playerproxy sets the combat mode to 1 a few seconds later, when everything is disabled again.

Thats how it works now in detail:
- Player runs into trigger_once,
- activates fight_banner (fight1). There I've named all images, as example "/hud/vshead_ghat.vtf", "/hud/vshead_talonco.vtf", etc...
- In the same time, fight_banner activates freezeplayer_game_ui (target !player) in the output after 0 seconds.
- Also fight_banner activates color_correction (materials/vs.raw) after 0 seconds.

- After 7 seconds, evething is disabled in fight_banner output: color_correction and freezeplayer_game_ui
- and fight_banner is disabled after 7 seconds.
- Also now combat mode is set to 1.

Whats happening now:
When running into the trigger, all fight banners show up like planned and they are disabled after 7 seconds. This works. What does not work is that "vs" isn't visible on the top center of the screen (is there a missing entity or something else?). Also not the whole game is freezing for a short time, just the player (because of !player as target, I assume. But I don't know how to set everything.) Also I can't see the changes via color_correction now, but this might be because of my computer in the moment (I am not at home and have just a bad computer for work here for the time).

What I find very strange is, that I can't find the fight_banner or other fighting related stuff in the maps with the entspy tool. Now I am not sure if this is because it's done in a different way in the official maps or if entspy just doesn't find these entities. First I thought, combat might be started via the scene files, so I opened some with Face Poser and checked it out... but saw just animations and sounds. Nothing regarding activating combat or whatever.

I don't know, what else I am still missing (also I am not sure about the 7 seconds. Right now, it's just a feeling tongue.gif).
Go to the top of the page
 
+Quote Post
Edmundo Bordeu
post Jan 19 2010, 11:07 AM
Post #2


Newbie
*

Group: Developers
Posts: 45
Joined: 14-April 08
Member No.: 5




Humm... it has been a while since the question was asked, but here is how it works..

We are not using a fight_banner entity: What we do is start the fight banner by giving an input to the point_clientcommand entity (for example):

Target: Console
Input: Command
With a parameter of: show_fight_banner gate_2

This will freeze everything, show the banners and the "vs".
The "gate_2" banner is one of many you can define in the folder zenozoik/resource/fight_banners (you could add more of your own .res files (editable with a text program), and change the characters who will appear)

You are correct about how we activated the colorcorrections. If it is not turning on/off, it is a colorcorrection related problem and not about the VS screens.
Go to the top of the page
 
+Quote Post
Lexx
post Jan 21 2010, 06:43 AM
Post #3


Newbie
*

Group: Members
Posts: 35
Joined: 30-November 09
From: Germany
Member No.: 1,027



Ah, this makes sense then. I was very curious about how the stuff works... I will try it this way. smile.gif

Also I am still working on my small project, but I just have very little time in the moment. So many stuff to do and just so little time...
Go to the top of the page
 
+Quote Post
tschumann
post Feb 18 2010, 08:05 PM
Post #4


Advanced Member
***

Group: Moderator
Posts: 747
Joined: 20-March 09
From: Australia
Member No.: 283



QUOTE (Lexx @ Dec 25 2009, 11:48 PM) *
tried to decompile some maps too, but this doesn't work because of prop errors.


You could try running vmex with the -p (I think) parameter so it skips the prop_static data, as that seems to be the only change in the .bsp format.
Go to the top of the page
 
+Quote Post
tschumann
post Feb 8 2011, 08:50 PM
Post #5


Advanced Member
***

Group: Moderator
Posts: 747
Joined: 20-March 09
From: Australia
Member No.: 283



QUOTE (tschumann @ Feb 19 2010, 10:05 AM) *
You could try running vmex with the -p (I think) parameter so it skips the prop_static data, as that seems to be the only change in the .bsp format.


As an update to this, someone has made a new .bsp decompiler that fully supports Zeno Clash maps: http://nuclearvelocity.com/barracuda/bspsrc/downloads.html
Go to the top of the page
 
+Quote Post

Fast ReplyReply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: