//

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Micro-Stuttering from hell (PC), Constant Micro-Stuttering even in menus...
DoucheFX
post Dec 7 2012, 04:42 PM
Post #1


Newbie
*

Group: Members
Posts: 6
Joined: 6-December 12
Member No.: 12,415



Hi there,

First of all thank you for this amazing game, it is insanely entertaining in multiplayer and the single player has its humor right where it should be! War has to be the most criminally fun game mode I've seen in a while.

That being said, I have to report a technical problem I have with the game and am hoping you guys can help me with it (a programmer will probably have to deal with this request). The game has a horrendous and steady micro-stuttering problem every 3 seconds and there is literally nothing I can do to prevent it, it makes the game generally irritating to the point of unplayability. But it doesn't stop there, the one and ONLY way I have found to stop the stuttering is either to bring up the steam overlay (I can see the balls rolling in the background without any stuttering) or to play in windowed mode and bring up something up front like the start menu or the task manager... Needless to say I am quite puzzled by this.

Here is what I have tried:
1. Played multiple UE3 engine games that are far more demanding on higher settings without a problem.

2. Completely obliterated both the game and all graphics drivers to try a bunch of them (namely catalyst 12.8, 12.10 and even beta 12.11, I reset settings to factory as an extra precaution).

3. Pretty much tested every possible combination of Catalyst settings available to modern men (I have a CrossFire setting and tweaked with it a lot).

4. Disabled 1, 2 and 3 cores to see if multi-core had anything to do with it.

5. Prayed to every last god there is, even the very pagan ones.

To no avail...

What I have noticed:
1. If I bring up the task manager while in windowed mode I have noticed that whenever the game is in the foreground and stuttering happens, the memory usage of the game keeps changing all the time; whenever it is behind the task manager or the start menu or anywhere not in the foreground, the stuttering stops and the memory usage for the game stops moving, it freezes and all is well.

2. While changing options in the BaseEngine.ini and DefaultEngine.ini managed to get me steady 60fps in split-screen war games (already an oddity it didn't before tweaking these because my rig can clearly run this game), the stuttering happened exactly at the same time intervals on any resolution/combination of settings.

My question is as follows:

Is there anything I can tweak in the ini files to make this thing disapear, or a windows option that can reproduce the behavior the game has when it is not in the foreground?

My guess is that it is constantly trying to access memory when in the foreground causing stuttering every time it refreshes useless things.

Thank you very much for your time and good day, sir,
FX

My specs: 8 GB SDRAM (not a matched pair), 500GB @ 7200rpm, AMD Radeon« HD 6720G2 1GB DDR3 VRAM (Crossfire between 6700M and 6520G), AMD« Fusion APU A6-3400M Processor.
Go to the top of the page
 
+Quote Post
tschumann
post Dec 7 2012, 06:18 PM
Post #2


Advanced Member
***

Group: Moderator
Posts: 737
Joined: 20-March 09
From: Australia
Member No.: 283



Have you tried playing with core affinity?
Are you able to get the game to display frame-rate and other statistics so you can check what happens when it goes in and out of focus? Sorry, not sure how to do this myself.
Go to the top of the page
 
+Quote Post
DoucheFX
post Dec 7 2012, 07:17 PM
Post #3


Newbie
*

Group: Members
Posts: 6
Joined: 6-December 12
Member No.: 12,415



I did try setting it to Core 0, Core 0 + 1 and Cores 1 + 2 + 3 + 4

Core 0 gave me a black screen with nothing happening when I launched the game forcing me to ctrl alt delete, core 1 + 2 + 3 + 4 gave stuttering and if I remember correctly, core 0 + 1 gave stuttering as well.

I did all this using RadeonPro not the taskmanager.

I will have to retest core 0 + 1 and try additional combinations to be sure, I'll do it later tonight, I have an Orchestra practice until then.

If you have additional suggestions in the meantime, have at it, I'll try them tonight.

Thanks for the quick reply!
Go to the top of the page
 
+Quote Post
DoucheFX
post Dec 7 2012, 10:54 PM
Post #4


Newbie
*

Group: Members
Posts: 6
Joined: 6-December 12
Member No.: 12,415



This situation keeps getting weirder and weirder...

I have tried every affinity setting possible to no avail, I did notice something new though.

The game only stops stuttering if the start menu or taskmanager are used to bring it to the background, in both cases, memory and cpu usage will stay static in taskmanager and the game will run like a charm.

If I use anything else like alt-tabbing to the catalyst control panel to bring the game to the background, the stuttering continues along with changes in cpu and ram use. It does so even if I go from there to the windows start menu or the task manager, the only way to stop the stuttering is to click on the game window and THEN use either the start menu key on my keyboard or ctrl-alt-del or alt-tab to go to the task manager...

Absolute nonsense to me.

I also tried switching the process to high low and realtime priority to no avail.
Go to the top of the page
 
+Quote Post
tschumann
post Dec 8 2012, 02:17 AM
Post #5


Advanced Member
***

Group: Moderator
Posts: 737
Joined: 20-March 09
From: Australia
Member No.: 283



Maybe try setting affinity through task manager if you haven't already.
Also, do you have a launch.log in My Documents\My Games\UnrealEngine3\BoulderGame\Logs ? If yes have a look and see if the everything is okay and if the game is seeing all of your RAM.

Hopefully someone who knows will tell you how to display FPS in-game so you can check what the stats are when the game is stuttering and when it isn't.

Also, do you have the latest version of the .NET framework installed?
Go to the top of the page
 
+Quote Post
DoucheFX
post Dec 8 2012, 04:54 AM
Post #6


Newbie
*

Group: Members
Posts: 6
Joined: 6-December 12
Member No.: 12,415



Wham fixed!

I installed the latest .NET version (4.5) and the stuttering went *poof*

I also asked RadeonPro to force high priority and to use cores 1 + 2 but I highly doubt it has anything to do with in since I had already tried that with cores 0 + 1 to no avail. I also tried every combination in task manager prior to this last attempt in RadeonPro.

Thank you very much tschumann, may your music live forever!


PS: The stuttering did not affect fps at all, I was still getting solid 60 without interruptions, as for the log it could see 7.5gb out of my total 8gb of RAM
Go to the top of the page
 
+Quote Post
tschumann
post Dec 8 2012, 07:21 PM
Post #7


Advanced Member
***

Group: Moderator
Posts: 737
Joined: 20-March 09
From: Australia
Member No.: 283



Glad to hear it.
In my searching I found someone else had a similar issue which was due to how frequently the .NET garbage collector was being called, so I thought that updating .NET might fix it - and it looks like it did.
Go to the top of the page
 
+Quote Post
blackrosegul
post Jan 8 2015, 03:35 AM
Post #8


Newbie
*

Group: Members
Posts: 1
Joined: 8-January 15
Member No.: 13,442



I go from there to the windows start menu or the task manager, the only way to stop the stuttering is to click on the game window and THEN use either the start menu key on my keyboard or ctrl-alt-del or alt-tab to go to the task manager...???
Go to the top of the page
 
+Quote Post
myloch
post Mar 3 2015, 11:21 AM
Post #9


Newbie
*

Group: Members
Posts: 3
Joined: 10-December 14
Member No.: 13,418



Don't hold your breath about this game getting some more fixes, they don't even care about fixing an evident bug with achievements. They only seem to care about milking a new cow. (facepalm)
Go to the top of the page
 
+Quote Post

Fast ReplyReply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th June 2017 - 11:42 AM